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This help file contains information about how to use this utility to view, edit and analyze a large project using VI
properties and VI metrics.
Sections of this help include:
Property Inspector Overview
Toolbar
Search Parameters
Results Table
Status Bar
Menu Bar
Settings
VI Scripting
Error Details
Examples
Support Resources

Property Inspector Overview
Property Inspector is a powerful utility for viewing, searching and editing VI properties of all VIs in a project, class or library. It allows
searching all the items based on 24 VI properties including VI Description, Data Size and Allow Debugging. After selecting all or
some of the results, 12 of the 24 specified VI properties can be edited for all VIs in a single click. Powerful string manipulation
functions allow for the entire field to be searched, edited, replaced or removed. It is also possible to modify a different VI property
than the one searched.
Property Inspector allows many search operations that are not allowed by LabVIEW, like finding any value, a missing value,
comparing a value against a threshold, or finding a value of True or False. Search Description for blank identifies Vis that need
documentation. Search LV Version for Less Than the current version will show all older code. Search Execution Status Equals ‘bad’
shows all broken code. Search Reentrant is True followed by Search In with Reentrancy Type Contains ‘Pre’ shows all Vis with
Preallocated Reentrancy. Searching a single property by True can quickly isolate all Vis with Allow Debugging, Auto Error Handling
or Modified status. Easily disable Allow Debugging on hundreds of VIs, compare the performance of your program, and then turn it
back on.
Flexible edit modes allow replacing a string with an empty value, replacing the whole string and not just the match, or removing a
path value by replacing it with Not-A-Path. Sorting all VIs by value would identify VIs with the highest Data Size, Code Size or
Revision Number. Unlike VI Profiler, the Data Size shows the memory used before the VI is executed and would identify static data
saved in the front panel or block diagram. All VIs are searched against the VIs in memory to determine if they are loaded In Memory.
Selected search results can all be edited, deleted, opened or run in a single operation. All opened windows can be closed with a
single operation. The visible details in the results window can be exported to a spreadsheet file for additional analysis or
documentation. The settings can configure which VI properties are displayed, allowing just the items of interest to be shown.
Powerful VI Scripting is included using the standard interfaces for VI Analyzer and Quick-Drop Plugins. This allows complex
operations to be performed on some or all Vis with just a small amount of your own code. Leveraging the existing library of
Community Quick-Drop Keyboard Plugins speeds the execution of standard operations like Align front panel controls to connector
pane pattern or Move block diagram contents to origin.
The utility keeps a history of the last 9 Search operations and each can be repeated in a single click. This history can also be cleared.
The utility can be found under the Tools menu -> Property Inspector… It currently only supports the items found under My
Computer.

Toolbar

Buttons on the toolbar speed operation of common functions. Some buttons are disabled if they don’t apply to the selection or can’t be used
during the current operation.

Open Project button
Press the Open Project button to browse for the project file to open. The project file cannot be newer than the current LabVIEW version. If the
project is older than the current version, any VIs edited would be updated to the current version.

Settings button
Opens the settings dialog. Options include the project object types, columns to display, search options, edit options and column sorting.

Filter on button
When a filter is applied, the Filter on button turns on. Click the filter on button to disable the filter and see the unfiltered results.

Open VI
When one or more VIs are selected, this button will open all VIs. Use the Window->Close opened windows to close them automatically

Refresh
When one or more VIs are selected, this button redraws the results for the selected row(s).

Back
Moves the selection one row higher in the results table. This button is only enabled if a result item is selected except the last one.

Next
Moves the selection one row lower in the results table. This button is only enabled if a result item is selected except the first one.

Search Parameters

Use the search parameters section to specify the properties or metrics to search by, the type of comparison and the value to display. Use the Edit
Mode and Edit Text to change the value of the selected results.

Search
Use this drop-down to select the VI property to search. Choices include:
Name

Description

Editable

Notes

ALL

Combines the text of all properties to simplify searching

No

Numbers are converted to text and will be
included in the results

Allow Debugging

VI Property found under Execution

Yes

Auto Error Handling

VI Property found under Execution

Yes

Block Diagram Size

VI Metric found under Memory Usage

No

Code Size

VI Metric found under Memory Usage

No

Data Size

VI Metric found under Memory Usage

No

Date Modified

File system property found on the disk

No

Description

VI Property found under Documentation

Yes

Execution State

VI State indicated by a broken run arrow

No

Front Panel Size

VI Metric found under Memory Usage

No

History Text

VI Property found under General, Revision History…

Yes

In Memory

VI Metric found by searching memory for each VI

No

Item Name

VI Property as shown in the project window

No

Item Path

VI Property as shown in the Files display under the
project. This path is relative to the project folder unless
the item is outside the project folder

No

Item Type

VI Property indicating the item type (Control VI,
Standard VI, Global VI, Folder, etc.)

No

Logging File Path

Used with Operate -> Data Logging

Yes

LV Version

VI Property found under General (Source version)

No

Modified

Hidden property shown when closing the project

Yes

Protection

VI Property found under Protection

Yes

Reentrant

VI Property found under Execution

Yes

Reentrancy Type

VI Property found under Execution (Shared or Prealloc)

Yes

Revision Number

VI Property found under General

Yes

Run Time Menu

Setting found under Edit->Run-Time Menu…

Yes

Same as VI Name

VI Property found under Window Appearance

Yes

Window Title

VI Property found under Window Appearance

Yes

May show as 0 if Separate Code from Source is
ON and the Vi is not in memory
Enter a date in mm/dd/yy format and use
Greater or Less Than. Just enter a year and
Less Than will use 1/1 and Greater Than 12/31

Can only be cleared (remove)

Modified only by saving

Remove to set to zero. When writing this
property, only replace with a value greater
than the current revision number.

Set Same as VI Name to False before setting

Compare Modes
Use this drop- to specify the comparison method. Text match case is an option specified in the settings.
String

Binary/String

Numeric

Equals

Includes results where the property or metric equals the specified string value

Contains

Includes results where the property or metric contains the specified string value

Excludes

Includes results where the property or metric excludes the specified string value

Starts With

Includes results where the property or metric starts with the specified string value

Ends With

Includes results where the property or metric ends with the specified string value

Is Blank/0/False

Includes results where the property or metric is a blank string or a 0 value. This includes
settings that are False.

Not Blank/True

Includes results where the property or metric is not blank string or a not a 0 value. This
includes settings that are True.

Less Than

Includes results where the Metric is less than the specified value. Strings are compared
character by character.

Greater Than

Includes results where the Metric is greater than the specified value. Strings are
compared character by character.

Value Field
Enter the value to search for or to filter out. Enter the text to include or exclude from the results.
String

Enter text

Enter the text to include or exclude from the results.

Binary/String

1/T/0/F

Enter a 1 or T for true and a 0 or F for false.

Numeric

Enter number

Enter the number to compare. Metric syntax is allowed including K for 1,000 and
M for 1,000,000. All value are integer except LabVIEW version, which returns a
decimal digit (i.e. 8.6).

Special

Reentrancy Type

Enter 0 or S for Shared or 1 or P for Pre-allocate

Search Button
Applies the search criteria to the entire project and displays the filtered results. This also sets the Filter On button.

Search In Button
Applies the search criteria to the displayed results window and displays the combined search results. This also sets the Filter On button. There is
no limit to the number of combined searches.

Edit Mode
Enter the how the edit is to be applied to the selected Search item. Note that it is possible to change the Search item and edit a different property
than was used to filter the results window.
Match

Replaces the part of the property that matches the filter by value with the edit text

Prepend

Inserts the edit text to the start of the filter by property

Append

Appends the edit text to the end of the filter by property

Replace

Replaces the entire property with the contents of the edit text, or True of False

Remove

Removes the entire property contents and leaves the field empty, false or Not-A-Path value

Edit Text
Enter the text to edit the property. If the Edit Text box is disabled, selected search property is not editable.

Edit Selected Button
Applies the Edit Mode to the Search property, optionally using the Edit Text and the Value Field

Results Table

This table shows the project items flattened into a row format with the details separated by columns. Use the settings dialog to select which
columns to display. The columns can optionally be sorted by the property name ascending or descending. The column widths can be adjusted by
dragging the dividers.
When the Filter On button is selected, the results table shows the filtered results. To edit VI properties, enter the change into the Edit Text box,
select the rows in the table to change and press the Edit Selected button. Note that the editing the results table does not edit the VI properties in
the VI.
Click on a column header to sort the results by the selected parameter. Click the same column to reverse the sort order. These sorting options can
also be selected by the View menu.

Status Bar

The status bar at the bottom of the window shows the current details of the project and the utility.
The left one-third shows the status of the toolbar and the Search Parameters. Messages include ‘Initializing’, ‘Opening’, ‘Ready’, ‘Searching’,
‘Replacing’, ‘No Items’, ‘No Results’, ‘No Selections’, ‘Enter 0, F, 1, or T’, ‘Enter Edit Text’, ‘Enter Current password’ and ‘Enter New Password’. If
the status shows ‘Cannot edit ????’, then the Search property is not editable. This is common for all VI metrics. Select a different property to
search by or perform an edit operation.
If the status is ‘No Selections’, one or more results must be selected for the edit operation.
The middle one-third shows the details of the selections in the results window. It shows total number of items in the project, number of items in
the filtered results (with percentage), number of items selected and the name of the item if only one is selected. Some operations include the total
time to complete the operation.
The right one-third shows the name of the selected project and it’s saved LabVIEW version.

Menu Bar
The menu bar includes several operation that are also on the toolbar, and several that only on the menu. Shortcut keys are shown by underlines,
just like in the menu. Hold the Alt key to use the shortcuts. Control shortcuts are available for some menu items shown with the (^) symbol. Items
in parenthesis are replaced by the actual content described.
File Menu

Open Project … (^O)
Open LVLib …
Open LVClass

Edit Menu

Close All
Save Selected
Save All
Export Results
Exit (^Q)
Select All (^A)
Deselect All (^D)
Invert Selection (^I)
Delete Selected VIs (^X)
Open Script Template
Select Script File
Run VI Script (^V)
Open QD Script Template

View Menu

Operate Menu
History Menu

Select QD Script File
Run QD Script (^R)
Sort By
Ascending
Open VIs
Run VIs
(History list)

Clear History
Search on Select (^0)
Window Menu

Help Menu

(Opened files)
(Opened projects)
Close Opened Windows

Show Edit Error Dialog
Show Help (F1)
Online Support and Resources
YouTube Videos
Search Examples
Alliance Member Page
Product Homepage
LabVIEW Tools Network
Community Quick Drop
Keyboard Shortcuts
About Property Inspector

Browses for a LabVIEW project file to load. An error shows if the Project file is
newer than the current LabVIEW version.
Browses for a LabVIEW library file to load (.LVLib). An error shows if the LVLib file is
newer than the current LabVIEW version.
Browses for a LabVIEW class file to load (.LVClass). An error shows if the LVClass file
is newer than the current LabVIEW version.
Closes the current project, library or class
Saves the selected items
Saves all the items in the results window
Exports the filtered results window to a spreadsheet file
Exits the utility and closes the open project
Selects all rows of the results window
Deselects all results
Inverts the selection. Selects all results that are not selected and deselects all
results that are selected
Deletes the selected Vis from the project. A confirmation dialog asks if Vis in autopopulating folders should be deleted from disk.
Opens a sample Script Template VI for creating custom scripts using the VI
Reference. The connector pane must not be modified.
Selects a custom Script File to run
Run the custom Script File on the selected items
Opens a sample QD Script Template VI for creating custom scripts using the VI
Reference. The connector pane must not be modified.
Selects a custom QD Script File to run
Run the custom QD Script File on the selected items
Select the property column to sort by. Clicking the column header will also change
the sort by setting. Select Unsorted to revert back to project order.
When checked the sort is ascending and unchecked is descending
Opens the selected VIs and controls
Opens and runs the selected VIs
This menu provides a quick and easy way to perform repetitive operation on several
projects or VIs. This list keeps a history of the last 9 filter operations. This list is
stored on disk and kept for every use. Duplicates are filtered out. If only No History
is shown, then there is no history.
This clears the list of history items
To speed repetitive operations, checking this option will perform the search on the
history selection immediately. Disable to perform Search In results.
This menu shows all the opened VIs.
This section of the menu shows all the opened projects
If a large number of items are opened by the Open VIs function, this menu item will
close them all at once. This option is only available when windows have been
opened by the utility
Displays the error dialog containing previous edit errors
Opens the help document (this one)
Opens the product support webpage
Opens a page with demonstration videos of the utility
Loads examples shown below into the search and edit criteria
Opens the NI Alliance Member directory page for ABCDEF
Opens the product page at abcdef.biz
Opens the product page on the LabVIEW Tools Network
Opens the NI forum page listing the latest Quick Drop Plugins
Displays the version number of the utility

Settings
The settings window allows control of project object types to include, columns to display, filter options, edit options and column sorting.

Object Types
Select the different types of project items to show in the results window. Types include VI, controls, classes, Xcontrols, Global VI, Polymorphic VI,
Configuration VI, Folder and Invalid items. Changes to Object Types will be applied when the project is reopened.

Columns to Display
Select the VI property and VI metrics to show in the results window. Items include Item Name, Item Type, Item Path, Window Title, Same as VI
Name, Execution State, Description, In Memory, Allow Debugging, Auto Error Handling, Date Modified, Code Size, Data Size, Front Panel Size, Block
Diagram Size, Reentrant, Reentrancy Type, LV Version, Revision Number, History Text, Protection, VI Logging Path and Run Time Menu. Turning off
the display of a column does not prevent it from being searched or edited.

Search Options
Match Case selects if text filters are case-independent or case-sensitive. Editing in Match mode will use the same case setting. Select Include
Dependencies to include them in the results.

Edit Options
Save Change will automatically save the VI after each edit operation. Close Item will close each VI. If Save Change is off and Close Item is on,
LabVIEW will prompt for every VI to be saved or not. Trim Description will Trim the whitespace from both ends of the Description before editing
the string. Use ‘\’ Codes will change the display of the Search Text and Edit Text to display \ codes.

Sort Columns
The result columns are pre-arranged in the same order as the Columns to Display setting. For convenience, all the columns may be sorted
alphabetically by the displayed name of the column. Options include ascending order and descending order.

VI Scripting
Scripting allows custom extension of the operation of the Property Inspector beyond the 11 properties that can currently be edited. In only a few
minutes, a scripting VI could be written to edit other properties or perform more complex edits. Leveraging the existing library of Quick Drop
shortcuts provides a quick and easy capability of performing common operations without writing any code.
Standard templates are provided to assist the creation of these scripts. The front panel must not be altered, since the script is called dynamically.
Save the modified script in any location and select it using the menu option. Then select all the Vis to be edited and run the script. Any errors
generated will be displayed by the Error Details dialog. Both selected scripts files are stored separately, allowing both to be used alternately. It is
possible to disable save and close for the first scripts and enable both for the last script run to minimize revisions.

VI Script
Use the included template VI based on the standard VI Analyzer template to write custom operations. PI will open the VI before the script and
optionally save and close it (based on settings dialog).

QD Script
Use the included template VI based on the standard Quick Drop template to write custom operations. If there are Quick Drop shortcuts installed
with LabVIEW, they can be used. Alternatively, use the included link in the Help menu to download pre-written QD scripts from the Quick Drop
Community. Use the Quick Drop Configuration panel to set the required options once for all VIs.
PI will open the VI before the script and optionally save and close it (based on settings dialog).

Error Details
If any errors are detected during the editing process, a dialog will list the VIs with the corresponding error codes and a description of the errors.
The total number of errors is also shown.

Export…
The list of errors with the details shown can be exported to a spreadsheet file for additional analysis or corrective actions.

Other Errors
Other error dialogs include: Project file is newer than current LabVIEW version, Library file is newer than current LabVIEW version, LVClass file is
newer than current LabVIEW version, No selection, No columns are displayed, Not all items could be deleted, Not all items could be opened and
Not all elements could be run.

Search Examples
Here are several useful examples of Property Inspector operations. The Property Inspector settings are expressed exactly as it appears on the
screen. Some examples show the edit operation with sample edit text and notes in parenthesis.
All of these examples can be found in the Help menu.

1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.

Description Starts With Use this template to, Remove
Description Is Blank/0/False, Replace (Description of each VI) (then press Next to advance to the next VI)
Allow Debugging Not Blank/True, Remove (remove will disable Allow Debugging)
Execution State Equals Bad
Data Size Greater Than 100K
VI Version Less Than 12
In Memory Is Blank/0/False (locates all VIs not in memory)
Auto Error Handling Not Blank/True, Remove
Is Reentrant Not Blank/True
Reentrancy Type Contains Pre, Replace S (Search In the results of example 9 to narrow the results)
Date Modified Less Than 2010
Modified Not Blank/True

Support Resources
For support with Property Inspector, use the following resources:
Website: http://www.abcdef.biz/support
Phone: 1-800-422-1523
Email: support@abcdef.biz
View quick demonstration Videos on the ABCDEF YouTube Channel

