
Page1 

Property Inspector Help 
Utility for managing VI properties and metrics from the project 

Version 3.0, January 2019, © 2013 - 2019 ABCDEF. All rights reserved. 
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Property Inspector Overview 
Property Inspector is a powerful utility for viewing, searching and editing VI properties of all VIs in a project, class or 
library.  It allows searching all the items based on 42 VI properties including VI Description, Data Size and Allow 
Debugging.  Some properties cannot be displayed in LabVIEW including Clones, Date Modified, Execution Status, In 
Memory, Inline is Allowed and Modified.  After selecting all or some of the results, 22 of the 42 specified VI properties 
can be edited for all VIs in a single click.  Powerful string manipulation functions allow for the entire field to be searched, 
edited, replaced or removed.  It is also possible to modify a different VI property than the one searched.  

Property Inspector supports many search criteria that are not allowed by LabVIEW, like finding any value, a missing 
value, comparing a value against a threshold, or finding a value of True or False.  Search Description for blank identifies 
Vis that need documentation. Search LV Version for Less Than the current version will show all older code. Search 
Execution Status Equals ‘bad’ shows all broken code.  Search Reentrant is True followed by Search In with Reentrancy 
Type Contains ‘Pre’ shows all Vis with Preallocated Reentrancy.  Searching a single property by True can quickly isolate 
all Vis with Allow Debugging, Auto Error Handling or Modified status.  Easily disable Allow Debugging on hundreds of 
VIs, compare the performance of your program, and then turn it back on. 

Flexible edit modes allow replacing a string with an empty value, replacing the whole string and not just the match, or 
removing a path value by replacing it with Not-A-Path. Sorting all VIs by value would identify VIs with the highest Data 
Size, Code Size or Revision Number.  Unlike VI Profiler, the Data Size shows the memory used before the VI is executed 
and would identify static data saved in the front panel or block diagram. All VIs are searched against the VIs in memory 
to determine if they are loaded In Memory. 

Selected search results can all be edited, deleted, opened or run in a single operation.  One click can show the block 
diagrams of all VIs or select them in the Project Explorer.  All opened windows can be closed with a single operation.  
The visible details in the results window can be exported to a spreadsheet file for additional analysis or documentation.  
The settings can enable all elements by 17 object types and which of the 42 VI properties are displayed, allowing just the 
items of interest to be shown. 

Two new features in Version 3.0 are Global Exclusion and Persistent Selection.  Searching the category ALL with a mode 
of Exclude allows a quick way to remove a specific set of items from the search.  Persistent Selection maintains the 
selection of all items in the window after changing Object Filters, Search or Sort settings. 

Powerful VI Scripting is included using the standard interfaces for VI Analyzer and Quick-Drop Plugins.  This allows 
complex operations to be performed on some or all Vis with just a small amount of your own code.  Leveraging the 
existing library of Community Quick-Drop Keyboard Plugins speeds the execution of standard operations like Align front panel 
controls to connector pane pattern or Move block diagram contents to origin.  VI Scripts can also be used to select project 
items using custom criteria. 

The utility keeps a history of the last 9 Search operations and each can be repeated in a single click.  Disabling Search on 
Select allows the history value to be edited before searching or compounded with Search In. This history can also be 
cleared. 

It optionally includes all targets found in the project including cRIO and FPGA targets. Another option will include all 
dependencies shown in the project. 

The utility can be found under the Tools menu -> Property Inspector…   

Installation Requirements 
Compatible LabVIEW Versions: >= 2014. 

Tested LabVIEW Versions: 2014, 2015, 2016, 2017 and 2018 

Compatible OS Versions: Windows, Mac. 

Hardware Requirements: None 

https://decibel.ni.com/content/docs/DOC-9573
https://decibel.ni.com/content/docs/DOC-13623
https://decibel.ni.com/content/docs/DOC-13623
https://decibel.ni.com/content/docs/DOC-30150
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Toolbar 

 
Buttons on the toolbar speed operation of common functions.  Some buttons are disabled if they don’t apply to the 
selection or can’t be used during the current operation. 

Open Project button 
Press the Open Project button to browse for the project file to open.  The project file cannot be newer than the current 
LabVIEW version.  If the project is older than the current version, any VIs edited would be updated to the current 
version. 

Settings button 
Opens the settings dialog.  Options include the project object types, columns to display, search options, edit options and 
column sorting. 

Filter on button 
When a filter is applied, the Filter on button turns on.  Click the filter on button to disable the filter and see the 
unfiltered results. 

Open VI 
When one or more VIs are selected, this button will open all VI front panels.  Holding the control key will show the block 
diagrams instead by minimizing the front panels. Use the Window->Close opened windows to close them automatically.  
Double-clicking a single item in the results window opens the front panel and holding control opens the block diagram.   

Refresh 
When one or more VIs are selected, this button redraws the results for the selected row(s). 

Back 
Moves the selection one row higher in the results table. This button is only enabled if a result item is selected except the 
last one. 

Next 
Moves the selection one row lower in the results table. This button is only enabled if a result item is selected except the 
first one. 
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Search Parameters 

 
Use the search parameters section to specify the properties or metrics to search by, the type of comparison and the 
value to display.  Use the Edit Mode and Edit Text to change the value of the selected results. 

Search drop-down 
Use this drop-down to select the VI property to search.  Choices include: 

Name Description Editable Notes 

ALL Combines all string properties to 
simplify searching and excluding 

No Compare options are Contains and Excludes 

Allow Debugging VI Property found under Execution Yes  

Auto Error 
Handling 

VI Property found under Execution Yes  

Block Diagram 
Size 

VI Metric found under Memory Usage No  

Callers Hidden property visible by selecting 
View->Browse Relationships->This VI’s 
Callers and then counting the VIs 
shown 

No  

Class Shown in the hierarchy of the project No  

Clones Hidden property  No Found by searching reentrant VIs in 
memory 

Code Complexity Shows the complexity factor used when 
compiled 

No Set 

Code Size VI Metric found under Memory Usage No May show as 0 if Separate Code from 
Source is ON and the Vi is not in memory 

Data Size VI Metric found under Memory Usage No  

Date Modified File system property found on the disk No Enter a date in mm/dd/yy format and use 
Greater or Less Than.  Just enter a year 
(2000 and later) and Less Than will use 1/1 
and Greater Than 12/31 

Description VI Property found under 
Documentation 

Yes  

Execution Priority VI Property found under Execution Yes Includes background (0), normal, above 
normal, high priority, time critical and sub-
routine (5).  Enter the first letter or 0 to 5 
to edit the value 

Execution State VI State indicated by a broken run 
arrow 

No Includes invalid, idle, running, bad, run top 
level 

File Size VI Metric shown under Memory Usage No Size of the VI file, LLB or library file 

Front Panel Size VI Metric found under Memory Usage No  
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History Text VI Property found under General, 
Revision History… 

Yes Can only be cleared (remove) 

In Memory VI Metric found by searching memory 
for each VI 

No  

Item Name VI Property as shown in the project 
window 

No  

Inline is Allowed Hidden property No Shows if Inline SubVI can be set to true 

Inline SubVI VI Property found under Execution Yes Allowed only if debugging is false and 
reentrant is set to pre-allocate 

Item Path VI Property as shown in the Files display 
under the project.  This path is relative 
to the project folder unless the item is 
outside the project folder 

No  

Item Type VI Property indicating the item type 
(Control VI, Standard VI, Global VI, 
Folder, etc.) 

No  

Library Shown in the hierarchy of the project No  

Logging File Path Used with Operate -> Data Logging Yes  

LV Version VI Property found under General 
(Source version) 

No  

Modified Hidden property shown when closing 
the project 

Yes Modified only by saving 

Monitor VI Property found under Window Run-
Time Pos 

Yes 0 = Primary, 1 or 2 sets the specific monitor 

Preferred 
Execution System 

VI Property found Execution, Preferred 
Execution System 

Yes Includes user interface, standard, 
instrument I/O, data acquisition, other 1, 
other 2, same as caller.  Use the first 4 
letters to edit the value or 1, 2 for other 

Protection VI Property found under Protection Yes  

Reentrant VI Property found under Execution Yes  

Reentrancy Type VI Property found under Execution 
(Shared or Prealloc) 

Yes  

Revision Number VI Property found under General Yes Remove to set to zero.  When writing this 
property, only replace with a value greater 
than the current revision number. 

Run Time Menu Setting found under Edit->Run-Time 
Menu… 

Yes  

Same as VI Name VI Property found under Window 
Appearance 

Yes  

Separate Comp. 
Code 

VI Property found under General 
(Separate compiled code from source 
file 

Yes  

Show front panel 
when called 

VI Property found under Window 
Appearance, Customize 

Yes  
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Show Menu Bar VI Property found under Window 
Appearance, Customize 

YES  

Suspend when 
Called 

VI Property found under the Operate 
menu 

Yes  

Target VI Property displayed in the bottom left 
corner of each VI after the project 
name 

No Typical values are My Computer, cRIO-xxxx 
or FPGA 

Total Data Size VI Metric shown under Memory Usage No This value is the sum of the other memory 
values 

Transparency VI Property found under Window 
Appearance, Customize 

Yes 0 to disable, 100 is completely transparent 

Window Behavior VI Property found under Window 
Appearance, Customize 

Yes Values include default, floating, floating-
hidden and Modal 

Window Title VI Property found under Window 
Appearance 

Yes Set Same as VI Name to False before 
setting 

Compare Modes 
Use this drop- to specify the comparison method. Text match case is an option specified in the settings. 

String  Equals Includes results where the property or metric equals the specified string 
value 

Contains Includes results where the property or metric contains the specified 
string value 

Excludes Includes results where the property or metric excludes the specified 
string value 

Starts With Includes results where the property or metric starts with the specified 
string value 

Ends With Includes results where the property or metric ends with the specified 
string value 

Binary/String Is 
Blank/0/False 

Includes results where the property or metric is a blank string or a 0 
value.  This includes settings that are False. 

Not 
Blank/True 

Includes results where the property or metric is not blank string or a not 
a 0 value. This includes settings that are True. 

Numeric Less Than Includes results where the Metric is less than the specified value.  Strings 
are compared character by character. 

Greater Than Includes results where the Metric is greater than the specified value.  
Strings are compared character by character. 

Value Field 
Enter the value to search for or to filter out.  Enter the text to include or exclude from the results. 

String  Enter text Enter the text to include or exclude from the results. 

Binary/String 1/T/0/F Enter a 1 or T for true and a 0 or F for false. 

Numeric Enter number Enter the number to compare.  Metric syntax is allowed including 
K for 1,024 and M for 1,048,576.  All value are integer except 
LabVIEW version, which returns a decimal digit (i.e. 8.6). 

Special Reentrancy Type Enter 0 or S for Shared or 1 or P for Pre-allocate 
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Search Button 
Applies the search criteria to the entire project and displays the filtered results.  This also sets the Filter On button. 

Search In Button 
Applies the search criteria to the displayed results window and displays the combined search results.  This also sets the 
Filter On button.  There is no limit to the number of combined searches. 

Edit Mode 
Enter the how the edit is to be applied to the selected Search item.  Note that it is possible to change the Search item 
and edit a different property than was used to filter the results window. 

Match Replaces the part of the property that matches the filter by value with the edit text, same 
as replace for binary settings 

Prepend Inserts the edit text to the start of the filter by property, same as replace for binary 
settings 

Append Appends the edit text to the end of the filter by property, same as replace for binary 
settings 

Replace Replaces the entire property with the contents of the edit text, or True or False, or 0 or 1 

Remove Removes the entire property contents and leaves the field empty, false or Not-A-Path 
value 

Edit Text 
Enter the text to edit the property.  If the Edit Text box is disabled, selected search property is not editable.  A multi-line 
string can be entered by pressing Control-Enter, or changing the settings to show slash codes (i.e. /r/n) 

Edit Selected Button 
Applies the Edit Mode to the Search property, optionally using the Edit Text and the Value Field 
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Results Table 

 
This table shows the project items flattened into a row format with the details separated by columns.  Use the settings 
dialog to select which columns to display.  The columns can optionally be sorted by the property name ascending or 
descending.  The column widths can be adjusted by dragging the dividers. Double-click a VI in the results table to open it. 

When the Filter On button is selected, the results table shows the filtered results.  To edit VI properties, enter the 
change into the Edit Text box, select the rows in the table to change and press the Edit Selected button.  Note that the 
editing the results table does not edit the VI properties in the VI. 

Click on a column header to sort the results by the selected parameter.  Click the same column to reverse the sort order.  
These sorting options can also be selected by the View menu. 

Status Bar 

 
The status bar at the bottom of the window shows the current details of the project and the utility.   

The left one-third shows the status of the toolbar and the Search Parameters.  Messages include ‘Initializing’, ‘Opening’, 
‘Ready’, ‘Searching’, ‘Replacing’, ‘No Items’, ‘No Results’, ‘No Selections’, ‘Enter 0, F, 1, or T’, ‘Enter Edit Text’, “Enter 
year or date (mm/dd/yy)”, ‘Enter Current password’ and ‘Enter New Password’.  If the status shows ‘Cannot edit ????’, 
then the Search property is not editable.  This is common for all VI metrics.  Select a different property to search by or 
perform an edit operation. 

If the status is ‘No Selections’, one or more results must be selected for the edit operation. 

The middle one-third shows the details of the selections in the results window.  It shows total number of items in the 
project, number of items in the filtered results (with percentage), number of items selected and the name of the item if 
only one is selected.  Some operations include the total time to complete the operation. 

The right one-third shows the name of the selected project and its saved LabVIEW version. 
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Menu Bar 

 
The menu bar includes several operations that are also on the toolbar, and several that only on the menu.  Shortcut keys 
are shown by underlines, just like in the menu.  Hold the Alt key to use the shortcuts.  Control shortcuts are available for 
some menu items shown with the (^) symbol.  Items in parenthesis are replaced by the actual content described. 

File Menu Open Project … (^O) Browses for a LabVIEW project file to load.  An error shows if the Project file 
is newer than the current LabVIEW version. 

Open LVLib … Browses for a LabVIEW library file to load (.LVLib).  
Open LVClass Browses for a LabVIEW class file to load (.LVClass).  
Reload Project Reloads the currently opened project to synchronize all items 
Close All Closes the current project, library or class 
Save Selected Saves the selected items 
Save All Saves all the items in the results window 
Export Results Exports the filtered results window to a spreadsheet file 
Exit (^Q) Exits the utility and closes the open project 

Edit Menu Select All (^A) Selects all rows of the results window 
Deselect All (^D) Deselects all results 
Invert Selection (^I) Inverts the selection.  Selects all results that are not selected and deselects 

all results that are 
Delete Selected VIs 
(^X) 

Deletes the selected Vis from the project.  A confirmation dialog asks if Vis 
in auto-populating folders should be deleted from disk. 

Open Script Template Opens a sample Script Template VI for creating custom scripts using the VI 
Reference.  The connector pane must not be modified. 

Select Script File Selects a custom Script File to run 
Run VI Script (^V) Run the custom Script File on the selected items 
Update Selections on 
Failure 

When checked, only the VI Scripts that return a failure will remain selected 

Open QD Script 
Template 

Opens a sample QD Script Template VI for creating custom scripts using the 
VI Reference.  The connector pane must not be modified. 

Select QD Script File Selects a custom QD Script File to run 
Run QD Script (^R) Run the custom QD Script File on the selected items 

View Menu Sort By Select the property column to sort by.  Clicking the column header will also 
change the sort by setting.  Select Unsorted to revert back to project order. 

Ascending When checked the sort is ascending and unchecked is descending 
Show VIs in Project Selects all VIs selected in the PI window in the LabVIEW Project window 

Operate 
Menu 

Open VIs Opens the selected VIs and controls 
Open Block Diagrams Opens the block diagrams of the selected VIs by minimizing the front panels 
Run VIs Opens and runs the selected VIs 

History 
Menu 

(History list) This menu provides a quick and easy way to perform repetitive operation 
on several projects or VIs.  This list keeps a history of the last 9 operations.  
This list is stored on disk and kept for every use.  Duplicates are filtered out.  
If only No History is shown, then there is no history. 

Clear History This clears the list of history items 
Search on Select (^0) To speed repetitive operations, checking this option will perform the search 

on the history selection immediately.  Disable to perform Search In results. 
(Opened files) This menu shows all the opened VIs. 
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Window 
Menu 

(Opened projects) This section of the menu shows all the opened projects 
Close Opened 
Windows 

If a large number of items are opened by the Open VIs function, this menu 
item will close them all at once.  This option is only available when windows 
have been opened by the utility 

Show Edit Error Dialog Displays the error dialog containing previous edit errors 
Help Menu Show Help (F1) Opens the help document (this one) 

Online Support and 
Resources 

Opens the product support webpage 

YouTube Videos Opens a page with demonstration videos of the utility 
Search Examples Loads examples shown below into the search and edit criteria 
Alliance Member Page Opens the NI Alliance Member directory page for ABCDEF 
Product Homepage Opens the product page at abcdef.biz 
LabVIEW Tools 
Network 

Opens the product page on the LabVIEW Tools Network 

Community Quick Drop 
Keyboard Shortcuts 

Opens the NI forum page listing the latest Quick Drop Plugins 

About Property 
Inspector 

Displays the version number of the utility 
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Settings 
The settings window allows control of project object types to include, columns to display, filter options, edit options and 
column sorting. 

 

Object Types 
Select the different types of project items to show in the results window.  Types include Standard VI, Control VI, Control 
– Typedef, Control – Strict TD, Global VI, Class Private Data, Property Definition, Class, Library, XControl, Polymorphic VI, 
Configuration VI, DAQmx, Variable, Folder, Document and other items.  Changes to Object Types will be applied 
immediately. 

Columns to Display 
Select the VI property and VI metrics to show in the results window. Items include Target, Item Name, Item Type, Item 
Path, Library, Class, Window Title, Same as VI Name, Execution State, Description, LV Version, In Memory, Allow 
Debugging, Auto Error Handling, Date Modified, Modified, Separate Compiled Code, Show FP when Called, Suspend 
when Called, Preferred Exec System, Execution Priority, Revision Number, History Text, Protection, Code Size, Data Size, 
Front Panel Size, Block Diagram Size, Total Data Size, File Size, Code Complexity, Reentrant, Reentrancy Type, Clones, 
Callers, Inline SubVI, Inline is Allowed, Transparency, Logging Path, Show Menu Bar, Run Time Menu and Monitor. 
Turning off the display of a column does not prevent it from being searched or edited. 
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Search Options 
Match Case selects if text filters are case-independent or case-sensitive.  Editing in Match mode will use the same case 
setting.  Select Include Dependencies to include them in the results.  Enable Include Targets to show cRIO and FPGA 
targets.  If a project is already loaded and this box is enabled the use File -> Reload Project to see the targets. 

Edit Options 
Save Change will automatically save the VI after each edit operation.  Close Item will close each VI.  If Save Change is off 
and Close Item is on, LabVIEW will prompt for every VI to be saved or not.  Trim Description will trim the whitespace 
from both ends of the Description before editing the string.  Use ‘\’ Codes will change the display of the Search Text and 
Edit Text to display \ codes. 

Sort Columns 
The result columns are pre-arranged in the same order as the Columns to Display settings.  For convenience, all the 
columns may be sorted alphabetically by the displayed name of the column.  Options include no sort, ascending order 
and descending order. 
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VI Scripting 
Scripting allows custom extension of the operation of the Property Inspector beyond the properties that can currently 
be edited.  In only a few minutes, a scripting VI could be written to search or edit other properties or perform more 
complex edits.  Leveraging the existing library of Quick Drop shortcuts provides a quick and easy capability of performing 
common operations without writing any code. 

Standard templates are provided to assist the creation of these scripts.  The front panel must not be altered, since the 
script is called dynamically.  Save the modified script in any location and select it using the menu option.  Then select all 
the Vis to be edited and run the script.  Any errors generated will be displayed by the Error Details dialog.  Both selected 
QuickDrop and VI scripts files are stored separately, allowing both to be used alternately.  It is possible to disable save 
and close for the first scripts and enable both for the last script run to minimize revisions. 

VI Script 
Use the included template VI based on the standard VI Analyzer template to write custom operations. PI will open the VI 
before the script and optionally save and close it (based on settings dialog).  If Update Selections on Failures is checked, 
then only the VIs that return an array of Results Data will remain selected.  This can be used to perform custom or 
complex search criteria.  The status bar in the center will display the number of failures and the selected items. 

 

QD Script 
Use the included template VI based on the standard Quick Drop template to write custom operations. If there are Quick 
Drop shortcuts installed with LabVIEW, they can also be used. Alternatively, use the included link in the Help menu to 
download pre-written QD scripts from the Quick Drop Community. Use the Quick Drop Configuration panel to set the 
required options once for all VIs. 

PI will open the VI before the script and optionally save and close it (based on settings dialog).   
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Error Details 
If any errors are detected during the editing process, a dialog will list the VIs with the corresponding error codes and a 
description of the errors.  The total number of errors is also shown. 

 

Export… 
The list of errors with the details shown can be exported to a spreadsheet file for additional analysis or corrective 
actions. 

Other Errors 
Other error dialogs include: Project file is newer than current LabVIEW version, Library file is newer than current 
LabVIEW version, LVClass file is newer than current LabVIEW version, No selection, No columns are displayed, Not all 
items could be deleted, Not all items could be opened and Not all elements could be run. 
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Search Examples 
Here are several useful examples of Property Inspector operations.  The Property Inspector settings are expressed 
exactly as it appears on the screen.  Some examples show the edit operation with sample edit text and notes in 
parenthesis.   

All of these examples can be found in the Help menu under Search Examples. 

1. Description Starts With Use this template to, Remove 
2. Description Is Blank/0/False, Replace (Description of each VI) (then press Next to advance to the next VI) 
3. Allow Debugging Not Blank/True, Remove (remove will disable Allow Debugging) 
4. Execution State Equals Bad 
5. Data Size Greater Than 100K 
6. VI Version Less Than 12 
7. In Memory Is Blank/0/False (locates all VIs not in memory) 
8. Auto Error Handling Not Blank/True, Remove 
9. Is Reentrant Not Blank/True 
10. Reentrancy Type Contains Pre, Replace S (Search In the results of example 9 to narrow the results) 
11. Date Modified Less Than 2010 
12. Separate Comp. Code Is Blank/0/False, Replace T 

 

Support Resources 
For support with Property Inspector, use the following resources: 

Website: http://support.abcdef.biz 

Phone: 1-800-422-1523 

Email: support@abcdef.biz 

View quick demonstration Videos on the ABCDEF YouTube Channel 

http://support.abcdef.biz/
mailto:support@abcdef.biz
https://www.youtube.com/channel/UCYbdvBKPyGZ0PDrZCABXUwA
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